Epoptes - Gerenciador de Laboratório

Fiz testes no Linux Educaional 3.0, e não tive êxito, pois não há versão do epoptes para versão hardy (versão do LE 3.0). Uma solução é a instalação do Italc, para instalá-lo clique aqui.
Instalando o epoptes no Linux educaional 4.0 e LE 5.0
Primeiramente vc deve adicionar o PPA do epoptes, em um terminal digite o comando seguinte:

sudo add-apt-repository ppa:epoptes

Caso não consiga adicionar o PPA leia este post:
http://aetjblog.blogspot.com.br/2012/07/erro-ao-tentar-adicionar-ppa.html


NO SERVIDOR
Após adicionar o PPA digite
sudo apt-get update (isto vai atualizar o repositório) 
sudo apt-get install epoptes  (no servidor)
digite: sudo gpasswd -a SEUUSUÁRIO epoptes (em SEUUSUARIO, coloque o nome do usuário que vc utiliza no servidor. no meu caso é professor.
Agora vc precisa pegar o nº IP do servidor: ainda no terminal digite ifconfig e anote o nº de IP que está no campo inet end, pois será usado nos clientes(alunos)

Obs: É aconselhável definir IP fixo no servidor, para isto faça o seguite:
Definindo IP fixo no Servidor (LE 4.0)
- Na barra inferior, clicar no ícone de conexões > Editar conexões;
- Na guia 'Sem fio' selecionar a rede (proinfo) e clicar ao lado, em 'Editar';
- Na guia 'Configurações IPv4 alterar 'Método' para 'Manual';
- Em 'Endereços' clicar ao lado em 'Adicionar'.
- Preencher 'Endereço' com 192.168.0.x, onde x é um numero de 1 à 253; depois 'Mascara de sub-rede' com 255.255.255.0; e, por último, 'Gateway' com 192.168.0.1, em "DNS" você pode colocar 8.8.8.8 ou o mesmo número do gateway.
- Click em salvar e pronto!
- Reiniciar a máquina para as alterações terem efeito.
NOS CLIENTES
Após adicionar o PPA digite
sudo apt-get update (isto vai atualizar o repositório)
sudo apt-get install epoptes-client
Abra o terminal e digite o seguinte comando
sudo kate /etc/default/epoptes-client (atenção, caso vc não consiga abrir o arquivo, vc precisa instalar o kate, basta digitar no terminal mesmo: sudo apt-get install kate) e tentar novamente sudo kate /etc/default/epoptes-client, salve as alterações
No arquivo que se abriu apagar o # antes do nome SERVER e substitua o valor depois do = pelo IP do servidor que vc anotou, no meu ficou assim
SERVER=192.168.0.10
Ainda no terminal para obter os certificados digite: sudo epoptes-client -c
REINICIE A MÁQUINA, vc já pode abrir o epoptes no servidor e visualizar as máquinas, iniciar>extras>epoptes.
Obs: O PPA utilizado neste post foi disponibilizado por Laércio de Souza no fórum do Le 4.0
 
Instalando Epoptes no Linux Educacional 5.0
NO SERVIDOR
Logado como professor abra um terminal e digite: su admin
 senha: admin 
depois digite:
 
sudo apt-get install epoptes  (no servidor)

digite: 
sudo gpasswd -a SEUUSUÁRIO epoptes (em SEUUSUARIO, coloque o nome do usuário que vc utiliza no servidor. no meu caso é professor)
 
Agora vc precisa pegar o nº IP do servidor: ainda no terminal digite ifconfig e anote o nº de IP que está no campo inet end, pois será usado nos clientes(alunos)

Obs: É aconselhável definir IP fixo no servidor, para isto faça o seguite:
NOS CLIENTES
Logado como professor abra um terminal e digite: su admin
senha: admin
digite: sudo apt-get install epoptes-client (aguarde instalação)
digite: sudo nano /etc/default/epoptes-client
encontre esta linha:
No arquivo que se abriu apagar o # antes do nome SERVER e substitua o valor depois do = pelo IP do servidor que vc anotou, no meu ficou assim:
SERVER=192.168.0.10
para salvar as alterações digite Ctrl+o, para sair Ctrl+x
ainda no terminal digite: sudo epoptes-client -c
reinicie a máquina 
Miguel Silva




43 comentários :

  1. Olá. Muito boa a sua dica.
    Tenho uma dúvida: no laboratório existe o LE 3.0 em todas as máquinas, elas são do pregão 83/2008, será que essa sua dica vale também pra o meu caso?

    []'s

    ResponderExcluir
  2. Olá, boa tarde, realizaei a instalação do epoptes nos clientes com Le 3.0 tudo certinho. Mas, não consigo visualizar estas maquinas no servidor. O servidor é um ubuntu 12.10. O que faço?

    att Marcos

    ResponderExcluir
  3. Olá Marcos,
    Infelismente o epoptes não se mostrou compatível com o LE 3.0, aconselhamos o uso do Italc, para Le3, ou a depender do pregão mudar para o LE 4 (recomendo).
    Para isntalar o italc clique neste link http://viniciuskarnopp.blogspot.com.br/2010/06/tutorial-de-instalacao-e-configuracao.html

    ResponderExcluir
  4. Boa tarde, mudar para o Le 4.0 não será possível porque as máquinas são muito antigas. No ubuntu 12.10, quando instalo o italc dá problema ao criar par de chaves. o que faço? Disseram que nos clientes o epoptes funcionaria no le 3.0

    att Marcos

    ResponderExcluir
  5. Qual erro ocorre quando tenta instalar o italc no Ubuntu 12,04?

    ResponderExcluir
  6. Desculpe esqueci de dizer, possuo pregao 45/2007 10 máquinas rodando o 4.0 com epoptes. Nestas máquinas tudo esta funcionando direitinho com acesso ao servidor ubuntu 12.10. Possuo 4 pc hp d325 onde instalei o Le 3.0 devido a possuir somente 256 de memoria cada máquina.

    att Marcos

    ResponderExcluir
  7. O italc instala normalmente, quando vou acessar dá um erro em ingles dizendo que nao foram encontradas chaves de autenticação e pede pra criar um novo par usando o ica. Outra pergunta não daria conflito de uso de porta do epoptes e do italc na mesma máquina?

    att Marcos

    ResponderExcluir
  8. Sobre este erro no ubuntu 12.10, não sei lhe dizer o que pode ser.
    Sobre dar ou não conflito, não se preocupe, eu utilizo os dois ao mesmo tempo e nunca tive problemas.

    ResponderExcluir
  9. Poderia verificar com alguem sobre este problema no ubuntu 12.10 para me ajudar?

    grato Marcos

    ResponderExcluir
  10. Olá Marcos, antes de inicar o italc no servidor, certifique-se de seguir todo os procedimentos deste Link: http://viniciuskarnopp.blogspot.com.br/2010/06/tutorial-de-instalacao-e-configuracao.html para só depois de reiniciar os computadores, poder abrir o italc no Servidor (ubuntu 12.10)

    ResponderExcluir
  11. Oi.
    Eu gostaria de instalar o Epoptes no Telecentro Comunitário do município, para prepara-lo para receber os mais diversos tipos de usuários, sejam para cursos ou para uso "livre" (se por assim dizer!). Por isso, eu gostaria de que me fossem tirados umas dúvidas:

    1 - Ao inicializar automaticamente nas máquinas clientes, posso fazer com que o programa execute de forma discreta, ou seja, sem que os usuários que esteja usando as máquinas saibam que estão sendo monitorados?

    2 - No servidor, o Epoptes abre a janela principal automaticamente ou é preciso abri-la manualmente?

    Como o uso desta magnífica ferramenta tem se demonstrado perfeitamente viável nos Pregões, estou pretendendo adotar a mesma em um ambiente mais geral.

    ResponderExcluir
  12. Olá Hipólito,
    O epoptes é executado automaticamente nos clientes, ou seja, eles não sabem que estão sendo monitorados, a não que vejam sua tela com programa aberto.
    No servidor, você precisa abrir o epoptes, para ter acesso, mas caso queira que ele inicie automaticamente ao logar no sistema, também é possível, basta dizer o sistema em que quer usar e lhe passamos os procedimentos.

    ResponderExcluir
  13. ola tudo bom
    eu instalei está funcionando quase bem, meu maior problema e que as vezes ele mostra todas as maquinas mas depois tem alguns tipo 2 ou 3 aleatoriamente somem? a net e wuariles, o roteador e o d-link do pregão 83/2008 assim como as maquinas será que um roteador mais potente pode resolver.

    ResponderExcluir
    Respostas
    1. Olá, sobre sumir, infelizmente é comum no epoptes, principalmente em rede wireless. Não sei o que ocorre. Neste ponto o italc é melhor.

      Excluir
  14. Respostas
    1. Olá Carlos, é o mesmo.
      Obrigado pelo contato.

      Excluir
  15. Alguém conseguiu instalar o epoptes nas maquinas do pregão com LE 5.0 ? tentei o procedimento acima porém sem sucesso alguém pode me dar uma ajuda ?

    ResponderExcluir
    Respostas
    1. Olá cutilado,
      Refiz a postagem, agora abordo também a instalação do epoptes no LE5, qualquer dúvida entre contato por aqui mesmo.
      Obrigado pelo contato.

      Excluir
    2. Esta instalação do LE5 funciona em multi-terminais com LE5???

      Excluir
    3. Olá Hécules de Campos Júnior,
      Não temos multiterminais aqui com le5, mas acredito que funcione, assim como funciona no le4.
      Obrigado pelo contato.

      Excluir
  16. Bom dia!
    Valeu mesmo Miguel, funcionou perfeitamente e o sistema encontra-se bem estável não caiu nem uma vez ainda.
    A única coisa que não funcionou foi a questão do desligamento que isso creio que seja um problema do próprio LE5. Tem alguma solução para funcionar este comando?
    Grande abraço...

    ResponderExcluir
  17. Olá cutilado.
    Que bom que funcionou.
    Sobre o desligamento pode ser que numa próxima atualização seja resolvido, acredito.
    Já testou desligar as máquinas pelo epoptes via linha de comando?

    ResponderExcluir
  18. Alguém sabe algum comando para abrir o libreOffice ?

    ResponderExcluir
    Respostas
    1. Olá Cutilado,
      O comando para o libreoffice é libreoffice mesmo, agora para o abrir o writer use o comando: libreoffice --writer
      Para saber o comando de um determinado aplicativo, clique com botão direito no menu LE, escolha a opção Editar Menu, na janela que se abrir selecione o programa, clique em propriedade e verique o que está escrito no campo comando.

      Excluir
    2. Opa Miguel tudo ok?
      Então não sei o que aconteceu aqui, mas o meu epoptes não quer mais abrir no servidor. Já tentei desistalar e instalar novamente porém sem sucesso continua não abrindo, sabe o que pode ser é LE5.

      Excluir
    3. Olá cutilado,
      tente abrir pelo terminal: abra o terminal e digite: epoptes, e verifique a mensagem de erro.

      Excluir
    4. Se eu digitar somente epoptes no terminal da essa mensagem de erro:

      Traceback (most recent call last):
      File "/usr/bin/epoptes", line 43, in
      from epoptes.ui import gui
      File "/usr/lib/python2.7/dist-packages/epoptes/ui/gui.py", line 45, in
      from execcommand import *
      File "/usr/lib/python2.7/dist-packages/epoptes/ui/execcommand.py", line 29, in
      from epoptes.common import config
      File "/usr/lib/python2.7/dist-packages/epoptes/common/config.py", line 217, in
      settings.set('GUI', 'messages_default_title', _('Message from administrator'))
      File "/usr/lib/python2.7/ConfigParser.py", line 396, in set
      raise NoSectionError(section)
      ConfigParser.NoSectionError: No section: 'GUI'

      Se eu digitar sudo epoptes ele diz que o usuario root precisa ser membro do grupo epoptes,

      Mas o usuario admin já é membro do grupo epoptes afinal eu usava sem problemas.

      O que acha que pode ser?

      Excluir
    5. Olá cutilado,
      Tente remover o epoptes da seguinte maneira: em um terminal digite: sudo apt-get --purge remove epoptes
      deste modo removerá o epoptes e suas configurações, depois reinstale-o novamente com o comando sudo apt-get install epoptes
      Se for algo referente a instalação do mesmo isto deve resolver. é o que posso dizer.

      Excluir
  19. Bom dia, Miguel!
    Gostei muito deste blog!! Parabéns a todos!
    Estou precisando de ajuda!
    No linux 4.0 o programa xsane não aparece no menu LE. Só consigo executar pelo terminal. Pergunto: Como coloca-lo no menu LE ou na barra de ferramentas? Como criar este atalho para este programa ou qualquer outro?
    Obrigado

    ResponderExcluir
    Respostas
    1. Olá José Lauro, acesse este vídeo: https://www.youtube.com/watch?v=jAHUz9GyQtg/ aqui mostro como criar o atalho, no campo comando vc pode procurar pelo programa que deseja abrir ou simplesmente escrever o comando do mesmo.
      Obrigado pelo contato!

      Excluir
    2. Obrigado pela atenção! Com a sua orinetação já resolvi o problema.

      Gostaria de outra orientação se possível.
      O LE4.0 me parece uma versão instável. Vire e mexe o icone de dispositivo conectado desaparece da barra. Voce tem alguma solução para reparar esta situação?

      Obrigado

      Excluir
    3. Olá José Lauro, nesse vídeo mostro como adicionar o ícone de dispositivos conectados no le4: https://www.youtube.com/watch?v=SdAJK97rJ-I&list=UUDJs4WtyPfm4Q6PNeKJ4WBw

      Excluir
  20. Ola boa tarde
    estou tendo problemas em instalar ele no LE 5 multi terminal ele nao da erro nenhum na hora que instala nos clientes mas o servidor nao reconhece as maquinas, ja retrei # da porta pois em alguns tutoriais pedia para fazer esse procedimento mas mesmo assim nada. vc poderia dar uma luz
    sem mais agradeço a atenção

    ResponderExcluir
    Respostas
    1. Olá,
      Verifique se o IP usado no arquivo "/etc/default/epoptes-client" está correto, deve ser o mesmo do servidor.
      Verifique se os multiterminais estão conectados na rede
      Tente gerar novamente os certificados em cada multiterminal usando o comando "sudo epoptes-client -c" e reinicie o computador.

      Excluir
    2. Ola Bom dia Miguel, fiz os teste e verifiquei as configurações nos pcs que ainda estão com LE4 e estao idênticas mas não reconhece as maquinas do pregão 23/2012 estão conectadas por cabo, e nas maquinas do pregão 71/2010 tem uma maquina que esta funcionando e fiz a mesma configuração nas outras e nada de funcionar se vc querer mando a fotos do programa para vc analisar e dar uma luz.
      sem mais já agradeço a ajuda.

      Excluir
    3. Olá Maike, você consegue acessar a internet nessas máquinas?

      Excluir
    4. Servidor Epoptes!!

      olá Mike eu tabém gostaria de saber se a uma solução o epoptes-client no LE 5.0 mult funciona super bem com servidor Epoptes com sistema LE 4.0 (reconhece todas as maquinas.
      Quando coloco o Servidor epoptes em uma maquina com LE 5.0 o Epoptes não encontra as Maquinas e devido a isso aqui tive que manter um servidor Epoptes com LE 4.0 para poder manter esse gerenciamento das sals de tecnologia. Agora até então não encontrei outra solução e se encontrarem espero que compartilhem esta solução!!

      Excluir
  21. Este comentário foi removido pelo autor.

    ResponderExcluir
  22. Instalei o epoptes aqui td funcionou consugo controlar as maquinas desligar e deslogar todas ao mesmo tempo enfim, porem a função bloquear usuario quando vou desbloquear nao desbloqueia as maquinas

    ResponderExcluir
    Respostas
    1. Olá, qual sistema operacional está usando?

      Excluir
  23. Olá bom dia. Trabalho no NTE de Santa Maria DF e fiz a instalação do servidor Epoptes em todas as máquinas do pregão 71/2010, 83/2008 e deram tudo certo funcionando muito bem. O problema é que não consigo instalar nas maquinas amarelas do pregão 23/2012 como clientes. Como servidor deu certo mas como clientes não instala, alguns arquivos não podem ser autenticados e não baixa. Em algumas maquinas desse pregão ate consegui instalar em uma escola, porém o servidor não as encontra. Alguem poderia me dizer o que posso fazer para solucionar esse problema.

    ResponderExcluir
  24. Utilizo em todos o Linux Educacional 5.0 Ubuntu 12.04

    ResponderExcluir